Is symfony/http-kernel 3.4 vulnerable?

Composer · 50 releases from 3.4.0 to 3.4.49 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. symfony/http-kernel 3.4.49, the last 3.4 release, is affected by 1 known security advisory (1 medium), including CVE-2022-24894. 1 more affects earlier 3.4.x releases. Upgrade to 4.4.50 or later to fix all of them.

Upgrade with:composer require symfony/http-kernel:^4.4.50

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/http-kernel 3.4.49

  • MediumCVE-2022-24894GHSA-h7vf-5wrv-9fhv1 Feb 2023

    Symfony storing cookie headers in HttpCache

    Affected
    >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
    Fixed in
    4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6

Fixed within 3.4.x, affecting earlier releases

  • HighCVE-2019-18887GHSA-q8hg-pf8v-cxrv26 Mar 2022

    Symfony Http-Kernel has non-constant time comparison in UriSigner

    Affected
    >=2.2.0 <2.8.52 · >=3.0.0 <3.4.35 · >=4.0.0 <4.2.12 · >=4.3.0 <4.3.8
    Fixed in
    2.8.52, 3.4.35, 4.2.12, 4.3.8

Which of your client projects are still on symfony/http-kernel 3.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-kernel versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.