Is symfony/process 6.3 vulnerable?

Composer · 5 releases from 6.3.0 to 6.3.12 · latest symfony/process is 8.1.10 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. symfony/process 6.3.12, the last 6.3 release, is affected by 1 known security advisory (1 high), including CVE-2024-51736. Upgrade to 6.4.14 or later to fix all of them.

Upgrade with:composer require symfony/process:^6.4.14

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/process 6.3.12

  • HighCVE-2024-51736GHSA-qq5c-677p-737q6 Nov 2024

    Symfony vulnerable to command execution hijack on Windows with Process class

    Affected
    <5.4.46 · >=6.0.0 <6.4.14 · >=7.0.0 <7.1.7
    Fixed in
    5.4.46, 6.4.14, 7.1.7

Which of your client projects are still on symfony/process 6.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/process version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/process versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.