Is symfony/process 7.0 vulnerable?
Composer · 6 releases from 7.0.0 to 7.0.8 · latest symfony/process is 8.1.10 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. symfony/process 7.0.8, the last 7.0 release, is affected by 1 known security advisory (1 high), including CVE-2024-51736. Upgrade to 7.1.7 or later to fix all of them.
Upgrade with:
composer require symfony/process:^7.1.7Advisories affecting symfony/process 7.0.8
Symfony vulnerable to command execution hijack on Windows with Process class
- Affected
- <5.4.46 · >=6.0.0 <6.4.14 · >=7.0.0 <7.1.7
- Fixed in
- 5.4.46, 6.4.14, 7.1.7
Which of your client projects are still on symfony/process 7.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/process version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/process versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.