Is symfony/security-http 4.3 vulnerable?

Composer · 12 releases from 4.3.0 to 4.3.11 · latest symfony/security-http is 8.1.10 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. symfony/security-http 4.3.11, the last 4.3 release, is affected by 2 known security advisories (2 high), including CVE-2026-48489, CVE-2026-45063. 1 more affects earlier 4.3.x releases. Upgrade to 5.4.53 or later to fix all of them.

Upgrade with:composer require symfony/security-http:^5.4.53

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/security-http 4.3.11

  • HighCVE-2026-48489GHSA-6h46-9jf5-q59x15 Jun 2026

    Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes

    Affected
    <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
    Fixed in
    5.4.53, 6.4.41, 7.4.13, 8.0.13
  • HighCVE-2026-45063GHSA-ph86-p8f6-f9r227 May 2026

    Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator

    Affected
    <5.4.52 · >=6.0.0-BETA1 <6.4.40 · >=7.0.0-BETA1 <7.4.12 · >=8.0.0-BETA1 <8.0.12
    Fixed in
    5.4.52, 6.4.40, 7.4.12, 8.0.12

Fixed within 4.3.x, affecting earlier releases

  • MediumCVE-2019-18886GHSA-4vpc-5jx4-cfqg2 Dec 2019

    User enumeration leak using switch user functionality in Symfony

    Affected
    >=4.1.0 <4.2.12 · >=4.3.0 <4.3.8
    Fixed in
    4.2.12, 4.3.8

Which of your client projects are still on symfony/security-http 4.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/security-http version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/security-http versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.