Is symfony/security-http 5.1 vulnerable?
Composer · 12 releases from 5.1.0 to 5.1.11 · latest symfony/security-http is 8.1.10 · checked 1 Nov 2026
Yes: 4 known advisories
Yes. symfony/security-http 5.1.11, the last 5.1 release, is affected by 4 known security advisories (2 high, 1 medium, 1 low), including CVE-2026-48489, CVE-2026-45063, CVE-2021-21424. Upgrade to 5.4.53 or later to fix all of them.
composer require symfony/security-http:^5.4.53Advisories affecting symfony/security-http 5.1.11
Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes
- Affected
- <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
- Fixed in
- 5.4.53, 6.4.41, 7.4.13, 8.0.13
Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator
- Affected
- <5.4.52 · >=6.0.0-BETA1 <6.4.40 · >=7.0.0-BETA1 <7.4.12 · >=8.0.0-BETA1 <8.0.12
- Fixed in
- 5.4.52, 6.4.40, 7.4.12, 8.0.12
User enumeration in authentication mechanisms
- Affected
- >=5.1.0 <5.2.8
- Fixed in
- 5.2.8
Prevent user enumeration using Guard or the new Authenticator-based Security
- Affected
- >=5.1.0 <5.2.8
- Fixed in
- 5.2.8
Which of your client projects are still on symfony/security-http 5.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/security-http version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/security-http versions
- symfony/security-http 5.4
- symfony/security-http 5.3
- symfony/security-http 5.2
- symfony/security-http 5.0
- symfony/security-http 4.4
- symfony/security-http 4.3
- symfony/security-http 8.1
- symfony/security-http 8.0
- symfony/security-http 7.4
- symfony/security-http 7.3
- symfony/security-http 7.2
- symfony/security-http 7.1
- All symfony/security-http advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.