Is tinymce/tinymce 4.5 vulnerable?
Composer · 11 releases from 4.5.0 to 4.5.12 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026
Yes: 14 known advisories
Yes. tinymce/tinymce 4.5.12, the last 4.5 release, is affected by 14 known security advisories (3 high, 11 medium), including CVE-2026-47761, CVE-2026-47762, CVE-2026-47759. Upgrade to 7.9.3 or later to fix all of them.
composer require tinymce/tinymce:^7.9.3Advisories affecting tinymce/tinymce 4.5.12
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option
- Affected
- <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
- Fixed in
- 5.11.0, 6.8.4, 7.2.0
TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements
- Affected
- <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
- Fixed in
- 5.11.0, 6.8.4, 7.2.0
TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes
- Affected
- <6.8.1
- Fixed in
- 6.8.1
TinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elements
- Affected
- <7.0.0
- Fixed in
- 7.0.0
TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodes
- Affected
- <5.10.9 · >=6.0.0 <6.7.3
- Fixed in
- 5.10.9, 6.7.3
TinyMCE XSS vulnerability in notificationManager.open API
- Affected
- >=6.0.0 <6.7.1 · <5.10.8
- Fixed in
- 5.10.8, 6.7.1
TinyMCE mXSS vulnerability in undo/redo, getContent API, resetContent API, and Autosave plugin
- Affected
- >=6.0.0 <6.7.1 · <5.10.8
- Fixed in
- 5.10.8, 6.7.1
Cross-site scripting vulnerability in TinyMCE alerts
- Affected
- >=6.0.0 <6.3.1 · <5.10.7
- Fixed in
- 5.10.7, 6.3.1
Cross-site scripting vulnerability in TinyMCE plugins
- Affected
- <5.10.0
- Fixed in
- 5.10.0
Cross-site scripting vulnerability in TinyMCE
- Affected
- <5.9.0
- Fixed in
- 5.9.0
Cross-site scripting vulnerability in TinyMCE
- Affected
- <5.6.0
- Fixed in
- 5.6.0
Which of your client projects are still on tinymce/tinymce 4.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other tinymce/tinymce versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.