Is tinymce/tinymce 8.9 vulnerable?
Composer · 4 releases from 8.9.0 to 8.9.3 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026
No known advisories in the last release
tinymce/tinymce 8.9.3, the last 8.9 release, has no known advisories. 1 advisory affects earlier 8.9.x releases, so update to 8.9.3.
Update within 8.9:
composer require tinymce/tinymce:^8.9.3Fixed within 8.9.x, affecting earlier releases
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
- Affected
- >=8.5.1 <8.9.3 · >=7.9.3 <7.9.4
- Fixed in
- 7.9.4, 8.9.3
Which of your client projects are still on tinymce/tinymce 8.9?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other tinymce/tinymce versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.