Is tinymce/tinymce 7.1 vulnerable?
Composer · 3 releases from 7.1.0 to 7.1.2 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. tinymce/tinymce 7.1.2, the last 7.1 release, is affected by 5 known security advisories (3 high, 2 medium), including CVE-2026-47761, CVE-2026-47762, CVE-2026-47759. Upgrade to 7.9.3 or later to fix all of them.
composer require tinymce/tinymce:^7.9.3Advisories affecting tinymce/tinymce 7.1.2
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option
- Affected
- <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
- Fixed in
- 5.11.0, 6.8.4, 7.2.0
TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements
- Affected
- <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
- Fixed in
- 5.11.0, 6.8.4, 7.2.0
Which of your client projects are still on tinymce/tinymce 7.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other tinymce/tinymce versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.