Is @hapi/hapi 18.4 vulnerable?
npm · 2 releases from 18.4.0 to 18.4.1 · latest @hapi/hapi is 21.4.12 · checked 2 Nov 2026
No known advisories in the last release
@hapi/hapi 18.4.1, the last 18.4 release, has no known advisories. 1 advisory affects earlier 18.4.x releases, so update to 18.4.1.
Update within 18.4:
npm install @hapi/hapi@18.4.1Fixed within 18.4.x, affecting earlier releases
Denial of Service in @hapi/hapi
- Affected
- <18.4.1 · >=19.0.0 <19.1.1
- Fixed in
- 18.4.1, 19.1.1
Which of your client projects are still on @hapi/hapi 18.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @hapi/hapi version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @hapi/hapi versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.