Is @hapi/hapi 19.1 vulnerable?
npm · 2 releases from 19.1.0 to 19.1.1 · latest @hapi/hapi is 21.4.12 · checked 1 Nov 2026
No known advisories in the last release
@hapi/hapi 19.1.1, the last 19.1 release, has no known advisories. 1 advisory affects earlier 19.1.x releases, so update to 19.1.1.
Update within 19.1:
npm install @hapi/hapi@19.1.1Fixed within 19.1.x, affecting earlier releases
Denial of Service in @hapi/hapi
- Affected
- <18.4.1 · >=19.0.0 <19.1.1
- Fixed in
- 18.4.1, 19.1.1
Which of your client projects are still on @hapi/hapi 19.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @hapi/hapi version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @hapi/hapi versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.