Is @hapi/hapi 19.0 vulnerable?
npm · 6 releases from 19.0.0 to 19.0.5 · latest @hapi/hapi is 21.4.12 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. @hapi/hapi 19.0.5, the last 19.0 release, is affected by 1 known security advisory (1 high). Upgrade to 19.1.1 or later to fix all of them.
Upgrade with:
npm install @hapi/hapi@19.1.1Advisories affecting @hapi/hapi 19.0.5
Denial of Service in @hapi/hapi
- Affected
- <18.4.1 · >=19.0.0 <19.1.1
- Fixed in
- 18.4.1, 19.1.1
Which of your client projects are still on @hapi/hapi 19.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @hapi/hapi version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @hapi/hapi versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.