Is crypto-js 3.2 vulnerable?

npm · 2 releases from 3.2.0 to 3.2.1 · latest crypto-js is 4.2.0 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. crypto-js 3.2.1, the last 3.2 release, is affected by 2 known security advisories (2 critical), including CVE-2026-71851, CVE-2023-46233. 1 more affects earlier 3.2.x releases. Upgrade to 4.2.0 or later to fix all of them.

Upgrade with:npm install crypto-js@4.2.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting crypto-js 3.2.1

  • CriticalCVE-2026-71851GHSA-rg76-677x-56q97 Aug 2026

    crypto-js: Insufficient Entropy in Cryptographic Secret Generation via Vulnerable CryptoJS Dependency Chain

    Affected
    <4.0.0
    Fixed in
    4.0.0
  • CriticalCVE-2023-46233GHSA-xwcq-pm8m-c4vf25 Oct 2023

    crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard

    Affected
    <4.2.0
    Fixed in
    4.2.0

Fixed within 3.2.x, affecting earlier releases

  • MediumCVE-2020-36732GHSA-3w3w-pxmm-2w2j12 Jun 2023

    crypto-js uses insecure random numbers

    Affected
    >=3.2.0 <3.2.1
    Fixed in
    3.2.1

Which of your client projects are still on crypto-js 3.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact crypto-js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other crypto-js versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.