Is crypto-js 3.3 vulnerable?
npm · 1 release from 3.3.0 to 3.3.0 · latest crypto-js is 4.2.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. crypto-js 3.3.0, the last 3.3 release, is affected by 2 known security advisories (2 critical), including CVE-2026-71851, CVE-2023-46233. Upgrade to 4.2.0 or later to fix all of them.
npm install crypto-js@4.2.0Advisories affecting crypto-js 3.3.0
crypto-js: Insufficient Entropy in Cryptographic Secret Generation via Vulnerable CryptoJS Dependency Chain
- Affected
- <4.0.0
- Fixed in
- 4.0.0
crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard
- Affected
- <4.2.0
- Fixed in
- 4.2.0
Which of your client projects are still on crypto-js 3.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact crypto-js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other crypto-js versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.