Is crypto-js 4.1 vulnerable?

npm · 2 releases from 4.1.0 to 4.1.1 · latest crypto-js is 4.2.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. crypto-js 4.1.1, the last 4.1 release, is affected by 1 known security advisory (1 critical), including CVE-2023-46233. Upgrade to 4.2.0 or later to fix all of them.

Upgrade with:npm install crypto-js@4.2.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting crypto-js 4.1.1

  • CriticalCVE-2023-46233GHSA-xwcq-pm8m-c4vf25 Oct 2023

    crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard

    Affected
    <4.2.0
    Fixed in
    4.2.0

Which of your client projects are still on crypto-js 4.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact crypto-js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other crypto-js versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.