Is engine.io 0.9 vulnerable?
npm · 1 release from 0.9.0 to 0.9.0 · latest engine.io is 6.6.11 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. engine.io 0.9.0, the last 0.9 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2020-36048, CVE-2022-41940. Upgrade to 3.6.1 or later to fix all of them.
Upgrade with:
npm install engine.io@3.6.1Advisories affecting engine.io 0.9.0
Uncaught exception in engine.io
- Affected
- <3.6.1 · >=4.0.0 <6.2.1
- Fixed in
- 3.6.1, 6.2.1
Resource exhaustion in engine.io
- Affected
- <3.6.0
- Fixed in
- 3.6.0
Which of your client projects are still on engine.io 0.9?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact engine.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other engine.io versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.