Is engine.io 6.5 vulnerable?
npm · 6 releases from 6.5.0 to 6.5.5 · latest engine.io is 6.6.11 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. engine.io 6.5.5, the last 6.5 release, is affected by 2 known security advisories (2 high), including CVE-2026-59724, CVE-2026-59725. Upgrade to 6.6.7 or later to fix all of them.
Upgrade with:
npm install engine.io@6.6.7Advisories affecting engine.io 6.5.5
Socket.IO: Engine.IO WebTransport SID DoS
- Affected
- >=6.5.0 <6.6.7
- Fixed in
- 6.6.7
Socket.IO: Engine.IO Polling Transport Connection Exhaustion
- Affected
- >=4.1.0 <6.6.7
- Fixed in
- 6.6.7
Which of your client projects are still on engine.io 6.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact engine.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other engine.io versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.