Is engine.io 6.4 vulnerable?

npm · 3 releases from 6.4.0 to 6.4.2 · latest engine.io is 6.6.11 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. engine.io 6.4.2, the last 6.4 release, is affected by 1 known security advisory (1 high), including CVE-2026-59725. 1 more affects earlier 6.4.x releases. Upgrade to 6.6.7 or later to fix all of them.

Upgrade with:npm install engine.io@6.6.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting engine.io 6.4.2

  • HighCVE-2026-59725GHSA-r635-g3xr-vw7x20 Jul 2026

    Socket.IO: Engine.IO Polling Transport Connection Exhaustion

    Affected
    >=4.1.0 <6.6.7
    Fixed in
    6.6.7

Fixed within 6.4.x, affecting earlier releases

  • MediumCVE-2023-31125GHSA-q9mw-68c2-j6m53 May 2023

    engine.io Uncaught Exception vulnerability

    Affected
    >=5.1.0 <6.4.2
    Fixed in
    6.4.2

Which of your client projects are still on engine.io 6.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact engine.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other engine.io versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.