Is engine.io 3.3 vulnerable?

npm · 3 releases from 3.3.0 to 3.3.2 · latest engine.io is 6.6.11 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. engine.io 3.3.2, the last 3.3 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2020-36048, CVE-2022-41940. Upgrade to 3.6.1 or later to fix all of them.

Upgrade with:npm install engine.io@3.6.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting engine.io 3.3.2

  • MediumCVE-2022-41940GHSA-r7qp-cfhv-p84w21 Nov 2022

    Uncaught exception in engine.io

    Affected
    <3.6.1 · >=4.0.0 <6.2.1
    Fixed in
    3.6.1, 6.2.1
  • HighCVE-2020-36048GHSA-j4f2-536g-r55m9 Feb 2022

    Resource exhaustion in engine.io

    Affected
    <3.6.0
    Fixed in
    3.6.0

Which of your client projects are still on engine.io 3.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact engine.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other engine.io versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.