Is engine.io 4.1 vulnerable?

npm · 3 releases from 4.1.0 to 4.1.2 · latest engine.io is 6.6.11 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. engine.io 4.1.2, the last 4.1 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2026-59725, CVE-2022-41940. 1 more affects earlier 4.1.x releases. Upgrade to 6.6.7 or later to fix all of them.

Upgrade with:npm install engine.io@6.6.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting engine.io 4.1.2

  • HighCVE-2026-59725GHSA-r635-g3xr-vw7x20 Jul 2026

    Socket.IO: Engine.IO Polling Transport Connection Exhaustion

    Affected
    >=4.1.0 <6.6.7
    Fixed in
    6.6.7
  • MediumCVE-2022-41940GHSA-r7qp-cfhv-p84w21 Nov 2022

    Uncaught exception in engine.io

    Affected
    <3.6.1 · >=4.0.0 <6.2.1
    Fixed in
    3.6.1, 6.2.1

Fixed within 4.1.x, affecting earlier releases

  • HighCVE-2022-21676GHSA-273r-mgr4-v34f13 Jan 2022

    Uncaught Exception in engine.io

    Affected
    >=4.0.0 <4.1.2 · >=5.0.0 <5.2.1 · >=6.0.0 <6.1.1
    Fixed in
    4.1.2, 5.2.1, 6.1.1

Which of your client projects are still on engine.io 4.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact engine.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other engine.io versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.