Is moment 1.7 vulnerable?
npm · 3 releases from 1.7.0 to 1.7.2 · latest moment is 2.31.0 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. moment 1.7.2, the last 1.7 release, is affected by 3 known security advisories (2 high, 1 medium), including CVE-2022-24785, CVE-2017-18214, CVE-2016-4055. Upgrade to 2.29.2 or later to fix all of them.
npm install moment@2.29.2Advisories affecting moment 1.7.2
Path Traversal: 'dir/../../filename' in moment.locale
- Affected
- <2.29.2
- Fixed in
- 2.29.2
Regular Expression Denial of Service in moment
- Affected
- <2.19.3
- Fixed in
- 2.19.3
Regular Expression Denial of Service in moment
- Affected
- <2.11.2
- Fixed in
- 2.11.2
Which of your client projects are still on moment 1.7?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact moment version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other moment versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.