Is moment 2.30 vulnerable?

npm · 2 releases from 2.30.0 to 2.30.1 · latest moment is 2.31.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. moment 2.30.1, the last 2.30 release, is affected by 1 known security advisory (1 medium), including CVE-2026-17495. Upgrade to 2.31.0 or later to fix all of them.

Upgrade with:npm install moment@2.31.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting moment 2.30.1

  • MediumCVE-2026-17495GHSA-4p3w-j4w9-5jqw29 Sept 2026

    moment vulnerable to Path Traversal via crafted non-string locale name

    Affected
    >=2.29.2 <2.31.0
    Fixed in
    2.31.0

Which of your client projects are still on moment 2.30?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact moment version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other moment versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.