Is moment 2.29 vulnerable?
npm · 5 releases from 2.29.0 to 2.29.4 · latest moment is 2.31.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. moment 2.29.4, the last 2.29 release, is affected by 1 known security advisory (1 medium), including CVE-2026-17495. 2 more affect earlier 2.29.x releases. Upgrade to 2.31.0 or later to fix all of them.
npm install moment@2.31.0Advisories affecting moment 2.29.4
moment vulnerable to Path Traversal via crafted non-string locale name
- Affected
- >=2.29.2 <2.31.0
- Fixed in
- 2.31.0
Fixed within 2.29.x, affecting earlier releases
Moment.js vulnerable to Inefficient Regular Expression Complexity
- Affected
- >=2.18.0 <2.29.4
- Fixed in
- 2.29.4
Path Traversal: 'dir/../../filename' in moment.locale
- Affected
- <2.29.2
- Fixed in
- 2.29.2
Which of your client projects are still on moment 2.29?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact moment version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other moment versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.