Is qs 1.0 vulnerable?

npm · 3 releases from 1.0.0 to 1.0.2 · latest qs is 6.17.1 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. qs 1.0.2, the last 1.0 release, is affected by 3 known security advisories (2 high, 1 medium), including CVE-2022-24999, CVE-2017-1000048, CVE-2025-15284. Upgrade to 6.14.1 or later to fix all of them.

Upgrade with:npm install qs@6.14.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting qs 1.0.2

  • MediumCVE-2025-15284GHSA-6rw7-vpxm-498p30 Dec 2025

    qs's arrayLimit bypass in its bracket notation allows DoS via memory exhaustion

    Affected
    <6.14.1
    Fixed in
    6.14.1
  • HighCVE-2022-24999GHSA-hrpp-h998-j3pp27 Nov 2022

    qs vulnerable to Prototype Pollution

    Affected
    >=6.10.0 <6.10.3 · >=6.9.0 <6.9.7 · >=6.8.0 <6.8.3 · >=6.7.0 <6.7.3 · >=6.6.0 <6.6.1 · >=6.5.0 <6.5.3 · >=6.4.0 <6.4.1 · >=6.3.0 <6.3.3 · <6.2.4
    Fixed in
    6.2.4, 6.3.3, 6.4.1, 6.5.3, 6.6.1, 6.7.3, 6.8.3, 6.9.7, 6.10.3
  • HighCVE-2017-1000048GHSA-gqgv-6jq5-jjj930 Apr 2020

    Prototype Pollution Protection Bypass in qs

    Affected
    <6.0.4 · >=6.1.0 <6.1.2 · >=6.2.0 <6.2.3 · >=6.3.0 <6.3.2
    Fixed in
    6.0.4, 6.1.2, 6.2.3, 6.3.2

Which of your client projects are still on qs 1.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact qs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other qs versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.