Is qs 0.6 vulnerable?
npm · 7 releases from 0.6.0 to 0.6.6 · latest qs is 6.17.1 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. qs 0.6.6, the last 0.6 release, is affected by 5 known security advisories (4 high, 1 medium), including CVE-2022-24999, CVE-2017-1000048, CVE-2014-10064. Upgrade to 6.14.1 or later to fix all of them.
npm install qs@6.14.1Advisories affecting qs 0.6.6
qs's arrayLimit bypass in its bracket notation allows DoS via memory exhaustion
- Affected
- <6.14.1
- Fixed in
- 6.14.1
qs vulnerable to Prototype Pollution
- Affected
- >=6.10.0 <6.10.3 · >=6.9.0 <6.9.7 · >=6.8.0 <6.8.3 · >=6.7.0 <6.7.3 · >=6.6.0 <6.6.1 · >=6.5.0 <6.5.3 · >=6.4.0 <6.4.1 · >=6.3.0 <6.3.3 · <6.2.4
- Fixed in
- 6.2.4, 6.3.3, 6.4.1, 6.5.3, 6.6.1, 6.7.3, 6.8.3, 6.9.7, 6.10.3
Prototype Pollution Protection Bypass in qs
- Affected
- <6.0.4 · >=6.1.0 <6.1.2 · >=6.2.0 <6.2.3 · >=6.3.0 <6.3.2
- Fixed in
- 6.0.4, 6.1.2, 6.2.3, 6.3.2
Denial-of-Service Extended Event Loop Blocking in qs
- Affected
- <1.0.0
- Fixed in
- 1.0.0
Denial-of-Service Memory Exhaustion in qs
- Affected
- <1.0.0
- Fixed in
- 1.0.0
Which of your client projects are still on qs 0.6?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact qs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other qs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.