Is shell-quote 1.10 vulnerable?

npm · 1 release from 1.10.0 to 1.10.0 · latest shell-quote is 1.12.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. shell-quote 1.10.0, the last 1.10 release, is affected by 1 known security advisory (1 critical), including CVE-2026-102422. Upgrade to 1.11.0 or later to fix all of them.

Upgrade with:npm install shell-quote@1.11.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting shell-quote 1.10.0

  • CriticalCVE-2026-102422GHSA-pqg4-j6r4-53mv6 Oct 2026

    shell-quote: `quote()` command injection via a line terminator in a token after a `{ comment }` token

    Affected
    >=1.8.4 <1.11.0
    Fixed in
    1.11.0

Which of your client projects are still on shell-quote 1.10?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact shell-quote version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other shell-quote versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.