Is shell-quote 1.8 vulnerable?

npm · 5 releases from 1.8.0 to 1.8.4 · latest shell-quote is 1.12.0 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. shell-quote 1.8.4, the last 1.8 release, is affected by 2 known security advisories (1 critical, 1 high), including CVE-2026-102422, CVE-2026-13311. 1 more affects earlier 1.8.x releases. Upgrade to 1.11.0 or later to fix all of them.

Upgrade with:npm install shell-quote@1.11.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting shell-quote 1.8.4

  • CriticalCVE-2026-102422GHSA-pqg4-j6r4-53mv6 Oct 2026

    shell-quote: `quote()` command injection via a line terminator in a token after a `{ comment }` token

    Affected
    >=1.8.4 <1.11.0
    Fixed in
    1.11.0
  • HighCVE-2026-13311GHSA-395f-4hp3-45gv20 Jul 2026

    shell-quote: Quadratic-complexity Denial of Service in `parse()` (CWE-407)

    Affected
    <1.9.0
    Fixed in
    1.9.0

Fixed within 1.8.x, affecting earlier releases

  • CriticalCVE-2026-9277GHSA-w7jw-789q-3m8p9 Jun 2026

    shell-quote quote() does not escape newlines in object .op values

    Affected
    >=1.1.0 <1.8.4
    Fixed in
    1.8.4

Which of your client projects are still on shell-quote 1.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact shell-quote version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other shell-quote versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.