Is shell-quote 0.1 vulnerable?
npm · 2 releases from 0.1.0 to 0.1.1 · latest shell-quote is 1.12.0 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. shell-quote 0.1.1, the last 0.1 release, is affected by 2 known security advisories (1 critical, 1 high), including CVE-2016-10541, CVE-2026-13311. Upgrade to 1.9.0 or later to fix all of them.
npm install shell-quote@1.9.0Advisories affecting shell-quote 0.1.1
shell-quote: Quadratic-complexity Denial of Service in `parse()` (CWE-407)
- Affected
- <1.9.0
- Fixed in
- 1.9.0
Potential Command Injection in shell-quote
- Affected
- <1.6.1
- Fixed in
- 1.6.1
Which of your client projects are still on shell-quote 0.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact shell-quote version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other shell-quote versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.