Is ws 0.8 vulnerable?

npm · 2 releases from 0.8.0 to 0.8.1 · latest ws is 8.22.1 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. ws 0.8.1, the last 0.8 release, is affected by 3 known security advisories (2 high, 1 low), including CVE-2016-10542, CVE-2016-10518. Upgrade to 1.1.5 or later to fix all of them.

Upgrade with:npm install ws@1.1.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ws 0.8.1

  • HighGHSA-5v72-xg48-5rpm4 Jun 2019

    Denial of Service in ws

    Affected
    >=0.6.0 <1.1.5 · >=2.0.0 <3.3.1
    Fixed in
    1.1.5, 3.3.1
  • HighCVE-2016-10542GHSA-6663-c963-2gqg18 Feb 2019

    DoS due to excessively large websocket message in ws

    Affected
    <1.1.1
    Fixed in
    1.1.1
  • LowCVE-2016-10518GHSA-2mhh-w6q8-5hxw18 Feb 2019

    Remote Memory Disclosure in ws

    Affected
    <1.0.1
    Fixed in
    1.0.1

Which of your client projects are still on ws 0.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ws version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ws versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.