Is ws 1.1 vulnerable?

npm · 6 releases from 1.1.0 to 1.1.5 · latest ws is 8.22.1 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. ws 1.1.5, the last 1.1 release, is affected by 1 known security advisory (1 high), including CVE-2026-48779. 2 more affect earlier 1.1.x releases. Upgrade to 5.2.5 or later to fix all of them.

Upgrade with:npm install ws@5.2.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ws 1.1.5

  • HighCVE-2026-48779GHSA-96hv-2xvq-fx4p15 Jun 2026

    ws: Memory exhaustion DoS from tiny fragments and data chunks

    Affected
    >=1.1.0 <5.2.5 · >=6.0.0 <6.2.4 · >=7.0.0 <7.5.11 · >=8.0.0 <8.21.0
    Fixed in
    5.2.5, 6.2.4, 7.5.11, 8.21.0

Fixed within 1.1.x, affecting earlier releases

  • HighGHSA-5v72-xg48-5rpm4 Jun 2019

    Denial of Service in ws

    Affected
    >=0.6.0 <1.1.5 · >=2.0.0 <3.3.1
    Fixed in
    1.1.5, 3.3.1
  • HighCVE-2016-10542GHSA-6663-c963-2gqg18 Feb 2019

    DoS due to excessively large websocket message in ws

    Affected
    <1.1.1
    Fixed in
    1.1.1

Which of your client projects are still on ws 1.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ws version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ws versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.