Is yaml 2.6 vulnerable?
npm · 2 releases from 2.6.0 to 2.6.1 · latest yaml is 2.9.1 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. yaml 2.6.1, the last 2.6 release, is affected by 1 known security advisory (1 medium), including CVE-2026-33532. Upgrade to 2.8.3 or later to fix all of them.
Upgrade with:
npm install yaml@2.8.3Advisories affecting yaml 2.6.1
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
- Affected
- >=2.0.0 <2.8.3 · >=1.0.0 <1.10.3
- Fixed in
- 1.10.3, 2.8.3
Which of your client projects are still on yaml 2.6?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other yaml versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.