Is yaml 1.10 vulnerable?
npm · 4 releases from 1.10.0 to 1.10.3 · latest yaml is 2.9.1 · checked 1 Nov 2026
No known advisories in the last release
yaml 1.10.3, the last 1.10 release, has no known advisories. 1 advisory affects earlier 1.10.x releases, so update to 1.10.3.
Update within 1.10:
npm install yaml@1.10.3Fixed within 1.10.x, affecting earlier releases
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
- Affected
- >=2.0.0 <2.8.3 · >=1.0.0 <1.10.3
- Fixed in
- 1.10.3, 2.8.3
Which of your client projects are still on yaml 1.10?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other yaml versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.