Is yaml 2.8 vulnerable?

npm · 5 releases from 2.8.0 to 2.8.4 · latest yaml is 2.9.1 · checked 1 Nov 2026

No known advisories in the last release

yaml 2.8.4, the last 2.8 release, has no known advisories. 1 advisory affects earlier 2.8.x releases, so update to 2.8.4.

Update within 2.8:npm install yaml@2.8.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 2.8.x, affecting earlier releases

  • MediumCVE-2026-33532GHSA-48c2-rrv3-qjmp25 Mar 2026

    yaml is vulnerable to Stack Overflow via deeply nested YAML collections

    Affected
    >=2.0.0 <2.8.3 · >=1.0.0 <1.10.3
    Fixed in
    1.10.3, 2.8.3

Which of your client projects are still on yaml 2.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other yaml versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.