Is livewire/livewire 0.0 vulnerable?

Composer · 15 releases from 0.0.1 to 0.0.15 · latest livewire/livewire is 4.4.8 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. livewire/livewire 0.0.15, the last 0.0 release, is affected by 1 known security advisory (1 high), including CVE-2024-47823. Upgrade to 2.12.7 or later to fix all of them.

Upgrade with:composer require livewire/livewire:^2.12.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting livewire/livewire 0.0.15

  • HighCVE-2024-47823GHSA-f3cx-396f-7jqp8 Oct 2024

    Livewire Remote Code Execution on File Uploads

    Affected
    >=3.0.0-beta.1 <3.5.2 · <2.12.7
    Fixed in
    2.12.7, 3.5.2

Which of your client projects are still on livewire/livewire 0.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other livewire/livewire versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.