Is livewire/livewire 3.6 vulnerable?
Composer · 5 releases from 3.6.0 to 3.6.4 · latest livewire/livewire is 4.4.8 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. livewire/livewire 3.6.4, the last 3.6 release, is affected by 1 known security advisory (1 medium), including CVE-2026-81887. 1 more affects earlier 3.6.x releases. Upgrade to 3.8.3 or later to fix all of them.
composer require livewire/livewire:^3.8.3Advisories affecting livewire/livewire 3.6.4
Livewire DOM-based cross-site scripting during client-side state handling
- Affected
- >=3.0.0-beta.1 <3.8.3 · >=4.0.0-beta.1 <4.3.4
- Fixed in
- 3.8.3, 4.3.4
Fixed within 3.6.x, affecting earlier releases
Livewire is vulnerable to remote command execution during component property update hydration
- Affected
- >=3.0.0-beta.1 <3.6.4
- Fixed in
- 3.6.4
Which of your client projects are still on livewire/livewire 3.6?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.