Is livewire/livewire 3.0 vulnerable?

Composer · 11 releases from 3.0.0 to 3.0.10 · latest livewire/livewire is 4.4.8 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. livewire/livewire 3.0.10, the last 3.0 release, is affected by 3 known security advisories (1 critical, 1 high, 1 medium), including CVE-2025-54068, CVE-2024-47823, CVE-2026-81887. Upgrade to 3.8.3 or later to fix all of them.

Upgrade with:composer require livewire/livewire:^3.8.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting livewire/livewire 3.0.10

  • MediumCVE-2026-81887GHSA-g3hc-697w-wm822 Sept 2026

    Livewire DOM-based cross-site scripting during client-side state handling

    Affected
    >=3.0.0-beta.1 <3.8.3 · >=4.0.0-beta.1 <4.3.4
    Fixed in
    3.8.3, 4.3.4
  • CriticalCVE-2025-54068GHSA-29cq-5w36-x7w317 Jul 2025

    Livewire is vulnerable to remote command execution during component property update hydration

    Affected
    >=3.0.0-beta.1 <3.6.4
    Fixed in
    3.6.4
  • HighCVE-2024-47823GHSA-f3cx-396f-7jqp8 Oct 2024

    Livewire Remote Code Execution on File Uploads

    Affected
    >=3.0.0-beta.1 <3.5.2 · <2.12.7
    Fixed in
    2.12.7, 3.5.2

Which of your client projects are still on livewire/livewire 3.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other livewire/livewire versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.