Is livewire/livewire 3.3 vulnerable?
Composer · 6 releases from 3.3.0 to 3.3.5 · latest livewire/livewire is 4.4.8 · checked 1 Nov 2026
Yes: 4 known advisories
Yes. livewire/livewire 3.3.5, the last 3.3 release, is affected by 4 known security advisories (1 critical, 1 high, 2 medium), including CVE-2025-54068, CVE-2024-47823, CVE-2026-81887. Upgrade to 3.8.3 or later to fix all of them.
composer require livewire/livewire:^3.8.3Advisories affecting livewire/livewire 3.3.5
Livewire DOM-based cross-site scripting during client-side state handling
- Affected
- >=3.0.0-beta.1 <3.8.3 · >=4.0.0-beta.1 <4.3.4
- Fixed in
- 3.8.3, 4.3.4
Livewire is vulnerable to remote command execution during component property update hydration
- Affected
- >=3.0.0-beta.1 <3.6.4
- Fixed in
- 3.6.4
Livewire Remote Code Execution on File Uploads
- Affected
- >=3.0.0-beta.1 <3.5.2 · <2.12.7
- Fixed in
- 2.12.7, 3.5.2
Cross-site Scripting in livewire/livewire
- Affected
- >=3.3.5 <3.4.9
- Fixed in
- 3.4.9
Which of your client projects are still on livewire/livewire 3.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact livewire/livewire version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other livewire/livewire versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.