Is smarty/smarty 5.0 vulnerable?
Composer · 3 releases from 5.0.0 to 5.0.2 · latest smarty/smarty is 5.8.5 · checked 2 Nov 2026
Yes: 4 known advisories
Yes. smarty/smarty 5.0.2, the last 5.0 release, is affected by 4 known security advisories (1 high, 3 medium), including CVE-2024-35226, CVE-2026-62993, CVE-2026-62996. Upgrade to 5.8.4 or later to fix all of them.
composer require smarty/smarty:^5.8.4Advisories affecting smarty/smarty 5.0.2
Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty Security stream restriction bypass through stream: resource
- Affected
- >=5.0.0 <5.8.4
- Fixed in
- 5.8.4
Smarty: Symlink path traversal out of trusted directories
- Affected
- >=5.0.0 <5.8.2 · <4.5.7
- Fixed in
- 4.5.7, 5.8.2
Smarty vulnerable to PHP Code Injection by malicious attribute in extends-tag
- Affected
- >=5.0.0 <5.1.1 · >=3.0.0 <4.5.3
- Fixed in
- 4.5.3, 5.1.1
Which of your client projects are still on smarty/smarty 5.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact smarty/smarty version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other smarty/smarty versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.