Is swiftmailer/swiftmailer 6.0 vulnerable?

Composer · 3 releases from 6.0.0 to 6.0.2 · latest swiftmailer/swiftmailer is 6.3.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. swiftmailer/swiftmailer 6.0.2, the last 6.0 release, is affected by 1 known security advisory (1 medium), including CVE-2024-28859. Upgrade to 6.2.5 or later to fix all of them.

Upgrade with:composer require swiftmailer/swiftmailer:^6.2.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting swiftmailer/swiftmailer 6.0.2

  • MediumCVE-2024-28859GHSA-wjv8-pxr6-5f4r18 Mar 2024

    Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency

    Affected
    >=4.0.0 <6.2.5
    Fixed in
    6.2.5

Which of your client projects are still on swiftmailer/swiftmailer 6.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact swiftmailer/swiftmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other swiftmailer/swiftmailer versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.