Is swiftmailer/swiftmailer 4.1 vulnerable?
Composer · 6 releases from 4.1.3 to 4.1.8 · latest swiftmailer/swiftmailer is 6.3.0 · checked 2 Nov 2026
Yes: 3 known advisories
Yes. swiftmailer/swiftmailer 4.1.8, the last 4.1 release, is affected by 3 known security advisories (2 critical, 1 medium), including CVE-2016-10074, CVE-2024-28859. Upgrade to 6.2.5 or later to fix all of them.
composer require swiftmailer/swiftmailer:^6.2.5Advisories affecting swiftmailer/swiftmailer 4.1.8
Swiftmailer Sendmail transport arbitrary shell execution
- Affected
- >=4.0.0 <5.2.1
- Fixed in
- 5.2.1
Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency
- Affected
- >=4.0.0 <6.2.5
- Fixed in
- 6.2.5
Swift Mailer mail transport Command Injection
- Affected
- <5.4.5
- Fixed in
- 5.4.5
Which of your client projects are still on swiftmailer/swiftmailer 4.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact swiftmailer/swiftmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other swiftmailer/swiftmailer versions
- swiftmailer/swiftmailer 5.0
- swiftmailer/swiftmailer 4.3
- swiftmailer/swiftmailer 4.2
- swiftmailer/swiftmailer 6.3
- swiftmailer/swiftmailer 6.2
- swiftmailer/swiftmailer 6.1
- swiftmailer/swiftmailer 6.0
- swiftmailer/swiftmailer 5.4
- swiftmailer/swiftmailer 5.3
- swiftmailer/swiftmailer 5.2
- swiftmailer/swiftmailer 5.1
- All swiftmailer/swiftmailer advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.