Is swiftmailer/swiftmailer 6.2 vulnerable?

Composer · 8 releases from 6.2.0 to 6.2.7 · latest swiftmailer/swiftmailer is 6.3.0 · checked 2 Nov 2026

No known advisories in the last release

swiftmailer/swiftmailer 6.2.7, the last 6.2 release, has no known advisories. 1 advisory affects earlier 6.2.x releases, so update to 6.2.7.

Update within 6.2:composer require swiftmailer/swiftmailer:^6.2.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 6.2.x, affecting earlier releases

  • MediumCVE-2024-28859GHSA-wjv8-pxr6-5f4r18 Mar 2024

    Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency

    Affected
    >=4.0.0 <6.2.5
    Fixed in
    6.2.5

Which of your client projects are still on swiftmailer/swiftmailer 6.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact swiftmailer/swiftmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other swiftmailer/swiftmailer versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.