Is swiftmailer/swiftmailer 5.0 vulnerable?

Composer · 4 releases from 5.0.0 to 5.0.3 · latest swiftmailer/swiftmailer is 6.3.0 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. swiftmailer/swiftmailer 5.0.3, the last 5.0 release, is affected by 3 known security advisories (2 critical, 1 medium), including CVE-2016-10074, CVE-2024-28859. Upgrade to 6.2.5 or later to fix all of them.

Upgrade with:composer require swiftmailer/swiftmailer:^6.2.5

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting swiftmailer/swiftmailer 5.0.3

  • CriticalGHSA-4qpj-gxxg-jqg429 May 2024

    Swiftmailer Sendmail transport arbitrary shell execution

    Affected
    >=4.0.0 <5.2.1
    Fixed in
    5.2.1
  • MediumCVE-2024-28859GHSA-wjv8-pxr6-5f4r18 Mar 2024

    Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency

    Affected
    >=4.0.0 <6.2.5
    Fixed in
    6.2.5
  • CriticalCVE-2016-10074GHSA-pr44-4jfr-286m17 May 2022

    Swift Mailer mail transport Command Injection

    Affected
    <5.4.5
    Fixed in
    5.4.5

Which of your client projects are still on swiftmailer/swiftmailer 5.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact swiftmailer/swiftmailer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other swiftmailer/swiftmailer versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.