Is tinymce/tinymce 7.8 vulnerable?
Composer · 1 release from 7.8.0 to 7.8.0 · latest tinymce/tinymce is 8.10.1 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. tinymce/tinymce 7.8.0, the last 7.8 release, is affected by 3 known security advisories (3 high), including CVE-2026-47761, CVE-2026-47762, CVE-2026-47759. Upgrade to 7.9.3 or later to fix all of them.
composer require tinymce/tinymce:^7.9.3Advisories affecting tinymce/tinymce 7.8.0
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
Which of your client projects are still on tinymce/tinymce 7.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other tinymce/tinymce versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.