Is tinymce/tinymce 7.9 vulnerable?
Composer · 4 releases from 7.9.0 to 7.9.3 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. tinymce/tinymce 7.9.3, the last 7.9 release, is affected by 1 known security advisory (1 high), including CVE-2026-116675. 3 more affect earlier 7.9.x releases. Upgrade to 7.9.4 or later to fix all of them.
composer require tinymce/tinymce:^7.9.4Advisories affecting tinymce/tinymce 7.9.3
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
- Affected
- >=8.5.1 <8.9.3 · >=7.9.3 <7.9.4
- Fixed in
- 7.9.4, 8.9.3
Fixed within 7.9.x, affecting earlier releases
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- Affected
- <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
- Fixed in
- 7.9.3, 8.5.1
Which of your client projects are still on tinymce/tinymce 7.9?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other tinymce/tinymce versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.