Is http-proxy-middleware 0.13 vulnerable?
npm · 1 release from 0.13.0 to 0.13.0 · latest http-proxy-middleware is 4.2.1 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. http-proxy-middleware 0.13.0, the last 0.13 release, is affected by 1 known security advisory (1 high), including CVE-2024-21536. Upgrade to 2.0.7 or later to fix all of them.
Upgrade with:
npm install http-proxy-middleware@2.0.7Advisories affecting http-proxy-middleware 0.13.0
Denial of service in http-proxy-middleware
- Affected
- <2.0.7 · >=3.0.0 <3.0.3
- Fixed in
- 2.0.7, 3.0.3
Which of your client projects are still on http-proxy-middleware 0.13?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy-middleware version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other http-proxy-middleware versions
- http-proxy-middleware 0.16
- http-proxy-middleware 0.15
- http-proxy-middleware 0.14
- http-proxy-middleware 0.12
- http-proxy-middleware 0.11
- http-proxy-middleware 0.10
- http-proxy-middleware 4.2
- http-proxy-middleware 4.1
- http-proxy-middleware 4.0
- http-proxy-middleware 3.0
- http-proxy-middleware 2.0
- All http-proxy-middleware advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.