Is http-proxy-middleware 0.16 vulnerable?

npm · 1 release from 0.16.0 to 0.16.0 · latest http-proxy-middleware is 4.2.1 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. http-proxy-middleware 0.16.0, the last 0.16 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2024-21536, CVE-2026-55602. Upgrade to 2.0.10 or later to fix all of them.

Upgrade with:npm install http-proxy-middleware@2.0.10

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting http-proxy-middleware 0.16.0

  • MediumCVE-2026-55602GHSA-64mm-vxmg-q3vj18 Jun 2026

    http-proxy-middleware `router` host+path substring matching allows Host-header-driven backend routing bypass

    Affected
    >=3.0.0 <3.0.6 · >=4.0.0 <4.1.0 · >=0.16.0 <2.0.10
    Fixed in
    2.0.10, 3.0.6, 4.1.0
  • HighCVE-2024-21536GHSA-c7qv-q95q-8v2719 Oct 2024

    Denial of service in http-proxy-middleware

    Affected
    <2.0.7 · >=3.0.0 <3.0.3
    Fixed in
    2.0.7, 3.0.3

Which of your client projects are still on http-proxy-middleware 0.16?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy-middleware version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other http-proxy-middleware versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.