Is shell-quote 1.1 vulnerable?

npm · 1 release from 1.1.0 to 1.1.0 · latest shell-quote is 1.12.0 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. shell-quote 1.1.0, the last 1.1 release, is affected by 3 known security advisories (2 critical, 1 high), including CVE-2026-9277, CVE-2016-10541, CVE-2026-13311. Upgrade to 1.9.0 or later to fix all of them.

Upgrade with:npm install shell-quote@1.9.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting shell-quote 1.1.0

  • HighCVE-2026-13311GHSA-395f-4hp3-45gv20 Jul 2026

    shell-quote: Quadratic-complexity Denial of Service in `parse()` (CWE-407)

    Affected
    <1.9.0
    Fixed in
    1.9.0
  • CriticalCVE-2026-9277GHSA-w7jw-789q-3m8p9 Jun 2026

    shell-quote quote() does not escape newlines in object .op values

    Affected
    >=1.1.0 <1.8.4
    Fixed in
    1.8.4
  • CriticalCVE-2016-10541GHSA-qg8p-v9q4-gh3418 Feb 2019

    Potential Command Injection in shell-quote

    Affected
    <1.6.1
    Fixed in
    1.6.1

Which of your client projects are still on shell-quote 1.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact shell-quote version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other shell-quote versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.