Is yaml 2.0 vulnerable?

npm · 2 releases from 2.0.0 to 2.0.1 · latest yaml is 2.9.1 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. yaml 2.0.1, the last 2.0 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2023-2251, CVE-2026-33532. Upgrade to 2.8.3 or later to fix all of them.

Upgrade with:npm install yaml@2.8.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting yaml 2.0.1

  • MediumCVE-2026-33532GHSA-48c2-rrv3-qjmp25 Mar 2026

    yaml is vulnerable to Stack Overflow via deeply nested YAML collections

    Affected
    >=2.0.0 <2.8.3 · >=1.0.0 <1.10.3
    Fixed in
    1.10.3, 2.8.3
  • HighCVE-2023-2251GHSA-f9xv-q969-pqx424 Apr 2023

    Uncaught Exception in yaml

    Affected
    >=2.0.0-5 <2.2.2
    Fixed in
    2.2.2

Which of your client projects are still on yaml 2.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other yaml versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.