Is symfony/http-kernel 5.0 vulnerable?
Composer · 12 releases from 5.0.0 to 5.0.11 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. symfony/http-kernel 5.0.11, the last 5.0 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2020-15094, CVE-2022-24894. Upgrade to 5.4.20 or later to fix all of them.
Upgrade with:
composer require symfony/http-kernel:^5.4.20Advisories affecting symfony/http-kernel 5.0.11
Symfony storing cookie headers in HttpCache
- Affected
- >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
- Fixed in
- 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
RCE in Symfony
- Affected
- >=4.3.0 <4.4.13 · >=5.0.0 <5.1.5
- Fixed in
- 4.4.13, 5.1.5
Which of your client projects are still on symfony/http-kernel 5.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/http-kernel versions
- symfony/http-kernel 5.3
- symfony/http-kernel 5.2
- symfony/http-kernel 5.1
- symfony/http-kernel 4.4
- symfony/http-kernel 4.3
- symfony/http-kernel 4.2
- symfony/http-kernel 8.1
- symfony/http-kernel 8.0
- symfony/http-kernel 7.4
- symfony/http-kernel 7.3
- symfony/http-kernel 7.2
- symfony/http-kernel 7.1
- All symfony/http-kernel advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.