Is symfony/http-kernel 5.3 vulnerable?

Composer · 17 releases from 5.3.0 to 5.3.16 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. symfony/http-kernel 5.3.16, the last 5.3 release, is affected by 1 known security advisory (1 medium), including CVE-2022-24894. 1 more affects earlier 5.3.x releases. Upgrade to 5.4.20 or later to fix all of them.

Upgrade with:composer require symfony/http-kernel:^5.4.20

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/http-kernel 5.3.16

  • MediumCVE-2022-24894GHSA-h7vf-5wrv-9fhv1 Feb 2023

    Symfony storing cookie headers in HttpCache

    Affected
    >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
    Fixed in
    4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6

Fixed within 5.3.x, affecting earlier releases

  • MediumCVE-2021-41267GHSA-q3j3-w37x-hq2q24 Nov 2021

    Webcache Poisoning in symfony/http-kernel

    Affected
    >=5.2.0 <5.3.12
    Fixed in
    5.3.12

Which of your client projects are still on symfony/http-kernel 5.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-kernel versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.