Is symfony/http-kernel 5.1 vulnerable?

Composer · 12 releases from 5.1.0 to 5.1.11 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. symfony/http-kernel 5.1.11, the last 5.1 release, is affected by 1 known security advisory (1 medium), including CVE-2022-24894. 1 more affects earlier 5.1.x releases. Upgrade to 5.4.20 or later to fix all of them.

Upgrade with:composer require symfony/http-kernel:^5.4.20

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/http-kernel 5.1.11

  • MediumCVE-2022-24894GHSA-h7vf-5wrv-9fhv1 Feb 2023

    Symfony storing cookie headers in HttpCache

    Affected
    >=2.0.0 <4.4.50 · >=5.0.0 <5.4.20 · >=6.0.0 <6.0.20 · >=6.1.0 <6.1.12 · >=6.2.0 <6.2.6
    Fixed in
    4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6

Fixed within 5.1.x, affecting earlier releases

  • HighCVE-2020-15094GHSA-754h-5r27-7x3r2 Sept 2020

    RCE in Symfony

    Affected
    >=4.3.0 <4.4.13 · >=5.0.0 <5.1.5
    Fixed in
    4.4.13, 5.1.5

Which of your client projects are still on symfony/http-kernel 5.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-kernel versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.